using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^option\s+[a-zA-Z0-9]+(?:\s?(?:(?:foo|bar|baz)(?:\s?test)?|test(?:\s?(?:foo|bar|baz))?))?$";
string input = @"option name1 foo
option name1 baz test
option name1 test bar
option name1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}