import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^option\\s+[a-zA-Z0-9]+(?:\\s?(?:(?:foo|bar|baz)(?:\\s?test)?|test(?:\\s?(?:foo|bar|baz))?))?$";
final String string = "option name1 foo\n"
+ "option name1 baz test\n"
+ "option name1 test bar\n"
+ "option name1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}