package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^option\s+[a-zA-Z0-9]+(?:\s?(?:(?:foo|bar|baz)(?:\s?test)?|test(?:\s?(?:foo|bar|baz))?))?$`)
var str = `option name1 foo
option name1 baz test
option name1 test bar
option name1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}