re = /^option\s+[a-zA-Z0-9]+(?:\s?(?:(?:foo|bar|baz)(?:\s?test)?|test(?:\s?(?:foo|bar|baz))?))?$/m
str = 'option name1 foo
option name1 baz test
option name1 test bar
option name1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end