using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^(?:\S+\s+\n?){1,2})\w+)";
string input = @"Brian Ball - working to make online income simple
((?:(\S+\s+){1,2})\w+)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}