re = /((^(?:\S+\s+\n?){1,2})\w+)/m
str = 'Brian Ball - working to make online income simple
((?:(\\S+\\s+){1,2})\\w+)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end