$re = '/(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()/]*)/m';
$str = 'TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80
TRANSPORT::FRTN_ASR9010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);