re = /(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()\/]*)/m
str = 'TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80
TRANSPORT::FRTN_ASR9010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end