import re
regex = re.compile(r"(?P<type>TRANSPORT)(?:::)(?P<desc>[\w#()/]*)", flags=re.MULTILINE)
test_str = ("TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80\n"
"TRANSPORT::FRTN_ASR9010")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")