package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\w+)\b[^\w]\p{L}+$`)
var str = `County Road 99
Sauk Centre, Minnesota 56378
USA`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}