const regex = /\b(\w+)\b[^\w]\p{L}+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)\\b[^\\w]\\p{L}+$', '')
const str = `County Road 99
Sauk Centre, Minnesota 56378
USA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}