$re = '/\b(\w+)\b[^\w]\p{L}+$/';
$str = 'County Road 99
Sauk Centre, Minnesota 56378
USA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);