re = /\b(\w+)\b[^\w]\p{L}+$/
str = 'County Road 99
Sauk Centre, Minnesota 56378
USA'
# Print the match result
str.match(re) do |match|
puts match.to_s
end