#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^[^()\n]+\([^()]*\)\s*" & @CRLF & _
"\{" & @CRLF & _
" (?:[^{}]*|(?R))+" & @CRLF & _
"\}"
Local $sString = "int firt(){" & @CRLF & _
" if () { " & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"customtype second(){" & @CRLF & _
" if () { " & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" for(){" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")