using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^()\n]+\([^()]*\)\s*
\{
(?:[^{}]*|(?R))+
\}";
string input = @"int firt(){
if () {
}
}
customtype second(){
if () {
}
for(){
}
}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}