re = /^[^()\n]+\([^()]*\)\s*
\{
(?:[^{}]*|(?R))+
\}/mx
str = 'int firt(){
if () {
}
}
customtype second(){
if () {
}
for(){
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end