package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^\][]*]\(([^()]*)\)`)
var str = `This [close](animal) is a dog`
var substitution = "{$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}