use strict;
my $str = 'This [close](animal) is a dog';
my $regex = qr/\[[^\][]*]\(([^()]*)\)/mp;
my $subst = '{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";