re = /\[[^\][]*]\(([^()]*)\)/m
str = 'This [close](animal) is a dog'
subst = '{$1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result