#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)(?'YMDyear'[\d]{4})?\/(?'YMDmonth'[\d]{2})\/(?'YMDday'[\d]{2})|(?'DMYday'[\d]{2})\/(?'DMYmonth'[\d]{2})\/(?'DMYyear'[\d]{4})"
Local $sString = "01/14/2020" & @CRLF & _
"" & @CRLF & _
"2020/01/31" & @CRLF & _
"" & @CRLF & _
"01/01/2020" & @CRLF & _
"" & @CRLF & _
"Test 01/01/1970" & @CRLF & _
"" & @CRLF & _
"Bla bla 01/01/1970 hello!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")