const regex = /(?'YMDyear'[\d]{4})?\/(?'YMDmonth'[\d]{2})\/(?'YMDday'[\d]{2})|(?'DMYday'[\d]{2})\/(?'DMYmonth'[\d]{2})\/(?'DMYyear'[\d]{4})/sigm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'YMDyear\'[\\d]{4})?\\\/(?\'YMDmonth\'[\\d]{2})\\\/(?\'YMDday\'[\\d]{2})|(?\'DMYday\'[\\d]{2})\\\/(?\'DMYmonth\'[\\d]{2})\\\/(?\'DMYyear\'[\\d]{4})', 'sigm')
const str = `01/14/2020
2020/01/31
01/01/2020
Test 01/01/1970
Bla bla 01/01/1970 hello!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}