// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sim)(?'YMDyear'[\d]{4})?\/(?'YMDmonth'[\d]{2})\/(?'YMDday'[\d]{2})|(?'DMYday'[\d]{2})\/(?'DMYmonth'[\d]{2})\/(?'DMYyear'[\d]{4})").unwrap();
let string = "01/14/2020
2020/01/31
01/01/2020
Test 01/01/1970
Bla bla 01/01/1970 hello!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}