use strict;
my $str = '01/14/2020
2020/01/31
01/01/2020
Test 01/01/1970
Bla bla 01/01/1970 hello!';
my $regex = qr/(?'YMDyear'[\d]{4})?\/(?'YMDmonth'[\d]{2})\/(?'YMDday'[\d]{2})|(?'DMYday'[\d]{2})\/(?'DMYmonth'[\d]{2})\/(?'DMYyear'[\d]{4})/simp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}