#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\(?\\?\"(\d{1,3}[-]?\d{0,3})[\s|,|,\s]?(.*[A-Za-z])\\?\",?(\d{1,2}?.?\d{3,9})?,?([-|+|\s]\d{1,2}?.?\d{3,9})?[A-Za-z]?\)?"
Local $sString = "("197 STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB",52.434992,-1.8990985)" & @CRLF & _
"(\"9-12, BOW STREET, LONDON, WC2E 7AH\",51.5136001,-0.1229336)" & @CRLF & _
"(\"14 STATION ROAD, LONDON SE20 7BQ\",51.41886,-0.0545021)" & @CRLF & _
"\"14 Station road London SE20 7BQ UK\"" & @CRLF & _
""14 Station road London SE20 7BQ UK"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1 $2 [$3] [$4]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)