// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\(?\\?\"(\d{1,3}[-]?\d{0,3})[\s|,|,\s]?(.*[A-Za-z])\\?\",?(\d{1,2}?.?\d{3,9})?,?([-|+|\s]\d{1,2}?.?\d{3,9})?[A-Za-z]?\)?"#).unwrap();
let string = "(\"197 STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB\",52.434992,-1.8990985)
(\\\"9-12, BOW STREET, LONDON, WC2E 7AH\\\",51.5136001,-0.1229336)
(\\\"14 STATION ROAD, LONDON SE20 7BQ\\\",51.41886,-0.0545021)
\\\"14 Station road London SE20 7BQ UK\\\"
\"14 Station road London SE20 7BQ UK\"
";
let substitution = "$1 $2 [$3] [$4]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}