# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[-*\h]|\d{4,})+/ /g;t' <<< "***Jack has* 777 1883874 -sheep-
2343klj-3***.net"