using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[-*\h]|\d{4,})+";
string substitution = @" ";
string input = @"***Jack has* 777 1883874 -sheep-
2343klj-3***.net";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}