// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[-*\h]|\d{4,})+").unwrap();
let string = "***Jack has* 777 1883874 -sheep-
2343klj-3***.net";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}