$re = '/(?:[-*\h]|\d{4,})+/';
$str = '***Jack has* 777 1883874 -sheep-
2343klj-3***.net';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;