package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*[aeiou][a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*`)
var str = `assignment number whatever what
topology
asstrwo
hop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}