$re = '/[a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*[aeiou][a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*/m';
$str = 'assignment number whatever what
topology
asstrwo
hop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);