re = /[a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*[aeiou][a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*/m
str = 'assignment number whatever what
topology
asstrwo
hop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end