package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z_+-]+)([0-9]+)`)
var str = `foo12
foo 42
foo.42
baz024902934108
baz_024902934108
baz+024902934108
baz-024902934108
baz 917971234
baz;12
baz9798797
baz:980
baz,980
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}