import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z_+-]+)([0-9]+)";
final String string = "foo12\n"
+ "foo 42\n"
+ "foo.42\n"
+ "baz024902934108\n"
+ "baz_024902934108\n"
+ "baz+024902934108\n"
+ "baz-024902934108\n"
+ "baz 917971234\n"
+ "baz;12\n"
+ "baz9798797\n"
+ "baz:980\n"
+ "baz,980\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}