re = /([A-Za-z_+-]+)([0-9]+)/m
str = 'foo12
foo 42
foo.42
baz024902934108
baz_024902934108
baz+024902934108
baz-024902934108
baz 917971234
baz;12
baz9798797
baz:980
baz,980
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end