use strict;
my $str = 'foo12
foo 42
foo.42
baz024902934108
baz_024902934108
baz+024902934108
baz-024902934108
baz 917971234
baz;12
baz9798797
baz:980
baz,980
';
my $regex = qr/([A-Za-z_+-]+)([0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}