import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?P<sense>(hay que)\\s.+?)|(?P<where>(en la|en el|en)\\s.+?)|(?P<what_time>(a las|a la)\\s.+?)|(?P<with>(para ellos|para el|para ellas|para ella|junto a|junto con)\\s.+?)|(?P<why>(por|porque)\\s.+?))(?=\\b(en la|en el|en|hay que|a las|a la|para ellos|para el|para ellas|para ella|junto a|junto con|por|porque|\\s$|$|[!\\.\\?]))";
final String string = "En la montaña de aquel frio lugar hay que estar preparados para largas noches frías junto a tus compañeros \n\n"
+ "Junto a tus compañeros en la montaña de aquel frio lugar hay que estar preparados para largas noches frías";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}