re = /((?P<sense>(hay que)\s.+?)|(?P<where>(en la|en el|en)\s.+?)|(?P<what_time>(a las|a la)\s.+?)|(?P<with>(para ellos|para el|para ellas|para ella|junto a|junto con)\s.+?)|(?P<why>(por|porque)\s.+?))(?=\b(en la|en el|en|hay que|a las|a la|para ellos|para el|para ellas|para ella|junto a|junto con|por|porque|\s$|$|[!\.\?]))/mi
str = 'En la montaña de aquel frio lugar hay que estar preparados para largas noches frías junto a tus compañeros
Junto a tus compañeros en la montaña de aquel frio lugar hay que estar preparados para largas noches frías'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end