const regex = new RegExp('((?P<sense>(hay que)\\s.+?)|(?P<where>(en la|en el|en)\\s.+?)|(?P<what_time>(a las|a la)\\s.+?)|(?P<with>(para ellos|para el|para ellas|para ella|junto a|junto con)\\s.+?)|(?P<why>(por|porque)\\s.+?))(?=\\b(en la|en el|en|hay que|a las|a la|para ellos|para el|para ellas|para ella|junto a|junto con|por|porque|\\s$|$|[!\\.\\?]))', 'gmi')
const str = `En la montaña de aquel frio lugar hay que estar preparados para largas noches frías junto a tus compañeros
Junto a tus compañeros en la montaña de aquel frio lugar hay que estar preparados para largas noches frías`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}