#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.{4,15}$)(^_?[A-Za-z0-9]*$|^[A-Za-z0-9]*_?$)"
Local $sString = "valid" & @CRLF & _
"_valid" & @CRLF & _
"valid_" & @CRLF & _
"inv" & @CRLF & _
"_invalid_" & @CRLF & _
"inv_alid" & @CRLF & _
"totallycool" & @CRLF & _
"123456789012345" & @CRLF & _
"1234567890123456" & @CRLF & _
"inval*d" & @CRLF & _
"inval!d" & @CRLF & _
"inval%d" & @CRLF & _
"invalid."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")