$re = '/(?=.{4,15}$)(^_?[A-Za-z0-9]*$|^[A-Za-z0-9]*_?$)/m';
$str = 'valid
_valid
valid_
inv
_invalid_
inv_alid
totallycool
123456789012345
1234567890123456
inval*d
inval!d
inval%d
invalid.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);