using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.{4,15}$)(^_?[A-Za-z0-9]*$|^[A-Za-z0-9]*_?$)";
string input = @"valid
_valid
valid_
inv
_invalid_
inv_alid
totallycool
123456789012345
1234567890123456
inval*d
inval!d
inval%d
invalid.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}