import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.{4,15}$)(^_?[A-Za-z0-9]*$|^[A-Za-z0-9]*_?$)";
final String string = "valid\n"
+ "_valid\n"
+ "valid_\n"
+ "inv\n"
+ "_invalid_\n"
+ "inv_alid\n"
+ "totallycool\n"
+ "123456789012345\n"
+ "1234567890123456\n"
+ "inval*d\n"
+ "inval!d\n"
+ "inval%d\n"
+ "invalid.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}