#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d*(\d)\1{2,})(\d{1,5})"
Local $sString = "1234567890" & @CRLF & _
"11234567890" & @CRLF & _
"11134567890" & @CRLF & _
"12345666890" & @CRLF & _
"" & @CRLF & _
"81234567890" & @CRLF & _
"811234567890" & @CRLF & _
"811134567890" & @CRLF & _
"12345666890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")