using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d*(\d)\1{2,})(\d{1,5})";
string input = @"1234567890
11234567890
11134567890
12345666890
81234567890
811234567890
811134567890
12345666890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}