const regex = new RegExp('^(?!\\d*(\\d)\\1{2,})(\\d{1,5})', 'gm')
const str = `1234567890
11234567890
11134567890
12345666890
81234567890
811234567890
811134567890
12345666890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}