re = /^(?!\d*(\d)\1{2,})(\d{1,5})/m
str = '1234567890
11234567890
11134567890
12345666890
81234567890
811234567890
811134567890
12345666890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end