package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|[?&])token=([^&]*)`)
var str = `key1=val1&token=val2&key3=val3
token=val1&key2=val2&key3=val3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}