$re = '/(?:^|[?&])token=([^&]*)/m';
$str = 'key1=val1&token=val2&key3=val3
token=val1&key2=val2&key3=val3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);