re = /(?:^|[?&])token=([^&]*)/m
str = 'key1=val1&token=val2&key3=val3
token=val1&key2=val2&key3=val3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end